php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69129 Floor, doesn't work at it shuld.
Submitted: 2015-02-26 21:48 UTC Modified: 2015-02-26 21:53 UTC
From: potarhere at gmail dot com Assigned:
Status: Not a bug Package: Filter related
PHP Version: 5.4.38 OS: Debian 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: potarhere at gmail dot com
New email:
PHP Version: OS:

 

 [2015-02-26 21:48 UTC] potarhere at gmail dot com
Description:
------------
I have found a small bug while using floor function.
The function isn't showing as I wanted (and the function were made for).

Cheers, Potar

Test script:
---------------
echo floor(2.9999999999999999); // 3
echo floor(2.999999999999999);  // 2


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-02-26 21:53 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2015-02-26 21:53 UTC] aharvey@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 14:03:46 2022 UTC