php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #69096 :D
Submitted: 2015-02-21 09:05 UTC Modified: 2015-02-21 09:40 UTC
From: pwwiur at mail dot com Assigned:
Status: Not a bug Package: Math related
PHP Version: 5.6.6 OS: unknown
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pwwiur at mail dot com
New email:
PHP Version: OS:

 

 [2015-02-21 09:05 UTC] pwwiur at mail dot com
Description:
------------
i dont know why it does't work
i am teacher and i saw it when i was teaching a part of math called Divisor



Test script:
---------------
<html>
<head>
<title>
arrays
</title>
<body>
<?php
$var=10;
for($i=1;$i=$var;$i++){
$b= $var % $i;
if($b=0){
echo $i;
}
}
?>
<br>
</body>
</html>

Expected result:
----------------
server cant show results

Actual result:
--------------
server cant show results

Patches

error (last revision 2015-02-21 09:10 UTC by pwwiur at mail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-02-21 09:40 UTC] mazzanet@php.net
-Status: Open +Status: Not a bug
 [2015-02-21 09:40 UTC] mazzanet@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This is a coding error and not a bug in PHP itself.

for($i=1;$i=$var;$i++){
           ^
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 22 07:01:25 2020 UTC