php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69075 Entry Point Not Found Error
Submitted: 2015-02-18 21:02 UTC Modified: 2015-02-23 16:05 UTC
From: jfha73 at gmail dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: master-Git-2015-02-18 (Git) OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jfha73 at gmail dot com
New email:
PHP Version: OS:

 

 [2015-02-18 21:02 UTC] jfha73 at gmail dot com
Description:
------------
Hey guys,

I just downloaded and compiled the latest of master, no problem there, but when I tried to load it I get an error saying: "The procedure entry point zval_is_true could not be located in the dynamic library php7ts.dll

Any ideas what went wrong?

Thanks

Expected result:
----------------
Load PHP as Apache2 Module

Actual result:
--------------
Error message

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-02-19 13:47 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2015-02-19 13:47 UTC] ab@php.net
Hi Jorge,

I cannot reproduce this. I just could guess that it's a dll hell issue. You probably should check which dll is indeed being loaded.

Cheers.
 [2015-02-19 14:26 UTC] jfha73 at gmail dot com
-Status: Feedback +Status: Open
 [2015-02-19 14:26 UTC] jfha73 at gmail dot com
My line in httpd.conf is:

LoadModule php7_module "D:/php7/php7apache2_4.dll"

Also, it won't show you when starting Apache, it will just fail to start, it will show if you run a

httpd -k status
 [2015-02-19 18:37 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2015-02-19 18:37 UTC] ab@php.net
Yeah, but please keep in mind, that it blames about php7ts.dll and Apache will do chroot. So on the console, before starting Apache, one should do

set path=D:\php7;%path%

Also, no other php7ts.dll should be in the Apache root. Or if Apache runs as a service, the path to php7 dir should precede anything else about PHP. Could you please try that?

Thanks.
 [2015-02-19 19:36 UTC] jfha73 at gmail dot com
-Status: Feedback +Status: Open
 [2015-02-19 19:36 UTC] jfha73 at gmail dot com
I only have 1 php7ts.dll and that's the one at D:\PHP7, the folder has never been in my %PATH% before and it has always worked, I'll try adding it, but what could have caused it? D:\PHP7 has never been in my path and it has worked every time, only this past few days it has stopped working.

Thanks Anatol.
 [2015-02-20 09:25 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2015-02-20 09:25 UTC] ab@php.net
To clear this out, you can use procmon from sysinternals https://technet.microsoft.com/en-us/sysinternals/bb896645.aspx to check from where a DLL was loaded.

What also comes in my mind - are you using some non core extensions there? It's currently unclear, what requires those symbols. But the core should be all good.

Cheers
 [2015-02-23 16:05 UTC] jfha73 at gmail dot com
-Status: Feedback +Status: Closed
 [2015-02-23 16:05 UTC] jfha73 at gmail dot com
Found the problem, the key word is "extension" I forgot that I always compiled my own with OCI support which was working before, but now that is not compiling OCI, the old one in place was causing this problem, once I took it off my php.ini it started working again.

Thanks again.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 13:03:33 2021 UTC