php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68953 reinstalling php removes the php.ini file from system
Submitted: 2015-01-29 23:18 UTC Modified: 2015-03-07 08:17 UTC
From: huda06_89 at hotmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.6.5 OS: SUSE Enterprise Server 10 SP 4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: huda06_89 at hotmail dot com
New email:
PHP Version: OS:

 

 [2015-01-29 23:18 UTC] huda06_89 at hotmail dot com
Description:
------------
I had successfully installed PHP at /usr/local/php.. but I didn't want to keep this path so I installed it with this command:
./configure'  '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-mysql' '--with-pear=/usr/local/pear

However, now php.ini file has dissapeard. It should be here: /usr/local/lib
but it is not there.. could you pls advise what is the problem? thank you

lnx22:/usr/local/lib # ls
php

lnx22:/usr/local/lib/php # ls *
build:
Makefile.global  acinclude.m4  config.guess  config.sub  libtool.m4  ltmain.sh  mkdep.awk  phpize.m4  run-tests.php  scan_makefile_in.awk  shtool

extensions:
no-debug-zts-20131226


Build Date => Jan 29 2015 18:07:02
Configure Command =>  './configure'  '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-mysql' '--with-pear=/usr/local/pear'
Server API => Command Line Interface
Virtual Directory Support => enabled
Configuration File (php.ini) Path => /usr/local/lib
Loaded Configuration File => (none)
Scan this dir for additional .ini files => (none)
Additional .ini files parsed => (none)
PHP API => 20131106
PHP Extension => 20131226
Zend Extension => 220131226
Zend Extension Build => API220131226,TS
PHP Extension Build => API20131226,TS



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-07 08:17 UTC] neeke@php.net
-Status: Open +Status: Not a bug
 [2015-03-07 08:17 UTC] neeke@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Php.ini files need to manually copy, this is not bug.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 13:04:05 2022 UTC