php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68918 Missing unlock
Submitted: 2015-01-26 23:31 UTC Modified: 2020-12-23 12:05 UTC
From: bugreports at internot dot info Assigned: cmb (profile)
Status: Not a bug Package: *General Issues
PHP Version: master-Git-2015-01-26 (Git) OS: Linux Ubuntu 14.04
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: bugreports at internot dot info
New email:
PHP Version: OS:

 

 [2015-01-26 23:31 UTC] bugreports at internot dot info
Description:
------------
Hi,

In /Zend/zend_ts_hash.c

25static void begin_read(TsHashTable *ht) 25static void begin_read(TsHashTable *ht)

in the function.


"ht->mx_writer" is never unlocked.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-30 09:58 UTC] danack@php.net
This doesn't look like an issue to me. The begin_read function is paired with the end_read function when it is used, and the end_read has the unlock for the mutex.
 [2020-12-23 12:05 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-12-23 12:05 UTC] cmb@php.net
What Dan said.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 16:05:45 2022 UTC