php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68811 Unchecked return value
Submitted: 2015-01-12 15:44 UTC Modified: 2017-08-13 19:31 UTC
From: bugreports at internot dot info Assigned:
Status: Duplicate Package: WDDX related
PHP Version: master-Git-2015-01-12 (Git) OS: Linux Ubuntu 14.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugreports at internot dot info
New email:
PHP Version: OS:

 

 [2015-01-12 15:44 UTC] bugreports at internot dot info
Description:
------------
Hi,

In /ext/wddx/wddx.c:

 885                        new_str = php_base64_decode(Z_STRVAL(ent1->data), Z_STRLEN(ent1->data));

this is unchecked against NULL, as it is done everywhere else. It may cause a null pointer dereference.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-08-13 19:31 UTC] cmb@php.net
-Status: Open +Status: Duplicate
 [2017-08-13 19:31 UTC] cmb@php.net
Closing as duplicate of bug #72750.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Aug 19 12:01:26 2019 UTC