php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #68744 Documentation for PDO Driver Interface missing
Submitted: 2015-01-04 22:25 UTC Modified: 2015-01-07 18:09 UTC
From: matjung at hotmail dot com Assigned:
Status: Not a bug Package: PDO related
PHP Version: 5.6.4 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: matjung at hotmail dot com
New email:
PHP Version: OS:

 

 [2015-01-04 22:25 UTC] matjung at hotmail dot com
Description:
------------
---
From manual page: http://www.php.net/pdo.drivers
---
Hello,
Maybe you can point me into the right direction.
I am looking for the specification of the PDO Interface.
The thing is that I would like to write a new PDO Driver for a database/back end system that is currently not available in PDO.

I could not find it at php.net and also not with searches on the internet.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-07 18:09 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2015-01-07 18:09 UTC] aharvey@php.net
We have this at http://php.net/manual/en/internals2.pdo.php. Note that you can only implement PDO drivers as extensions, not in userland PHP code.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Mar 08 02:01:26 2021 UTC