php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68722 Memory leaks
Submitted: 2015-01-02 09:22 UTC Modified: 2021-09-30 15:03 UTC
From: bugreports at internot dot info Assigned: cmb (profile)
Status: Not a bug Package: XMLRPC-EPI related
PHP Version: master-Git-2015-01-02 (Git) OS: Linux Ubuntu 14.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugreports at internot dot info
New email:
PHP Version: OS:

 

 [2015-01-02 09:22 UTC] bugreports at internot dot info
Description:
------------
Hi,

In the file /ext/xmlrpc/libxmlrpc/xmlrpc.c:


 818            xml_element_to_DANDARPC_REQUEST(request, root_elem);
leaks memory, as it actually returns storage.

as does
 822                                xml_element_to_SOAP_REQUEST (request, root_elem);

and

 826            xml_element_to_XMLRPC_REQUEST(request, root_elem);



And in /ext/xmlrpc/libxmlrpc/xml_to_soap.c:

662                        }
leaks 'rpc'




and in /ext/xmlrpc/libxmlrpc/system_methods.c:

366   return xReturn;
leaks 'xIntro', and 'xFaults'


and in /ext/xmlrpc/libxmlrpc/xmlrpc_introspection.c:

240      }

leaks 'xTypesArray'







Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-05-22 21:31 UTC] cristinagrca at yahoo dot com
The following pull request has been associated:

Patch Name: Update ext/oci8 methodsynopses based on stubs
On GitHub:  https://github.com/php/doc-en/pull/601
Patch:      https://github.com/php/doc-en/pull/601.patch
 [2021-05-22 21:31 UTC] cristinagrca at yahoo dot com
The following pull request has been associated:

Patch Name: Provide documentation for many ext/sodium functions
On GitHub:  https://github.com/php/doc-en/pull/592
Patch:      https://github.com/php/doc-en/pull/592.patch
 [2021-09-30 15:03 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-09-30 15:03 UTC] cmb@php.net
>  818            xml_element_to_DANDARPC_REQUEST(request, root_elem);
> leaks memory, as it actually returns storage.

Can a function leak memory if it is never called[1]?  I don't
think so. This is why such code review especially in a bundled
third-party library is pretty useless.  Feel free to report
upstream[2].

[1] <https://heap.space/search?project=PHP-7.4&full=&defs=&refs=XMLRPC_VALUE_FromXML&path=&hist=&type=>
[2] <http://xmlrpc-epi.sourceforge.net/>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 27 01:03:34 2021 UTC