php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #687 When using PHP and JavaScript, JS command document.lastModified gives bad date
Submitted: 1998-08-23 16:37 UTC Modified: 1998-08-23 16:47 UTC
From: gemstone at triax dot com Assigned:
Status: Closed Package: Other
PHP Version: 3.0.3 OS: Apache 1.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gemstone at triax dot com
New email:
PHP Version: OS:

 

 [1998-08-23 16:37 UTC] gemstone at triax dot com
<html>
<head>
<title>PHP/JavaScript Conflict</title>
</head>
<body>

<?
     require("anything.inc");
     // anything here will work, doesnt even have to be a require...
?>
<br>
JavaScript Last Modified: 
<script language="JavaScript">
     // print out the date the document was last modified
     document.write(document.lastModified);
     // returns 12/31/69 16:00:00
     // when PHP is removed from the page, then it returns the correct date
</script>

</body>
</html>

I dont have a clue what modules might be used, you'll have to contact Teleport (teleport.com)
Same goes for the ini file and other info.  

If you would prefer, I can contact them myself and if they cannot resolve the problem, have them contact you.

Thanks for your help either way,
Joshua James

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-08-23 16:47 UTC] rasmus
Not a bug.  If you want a last-modified header from a dynamically generated page, you should send one using the PHP Header() function.  Alternatively you can turn on the last_modified directive in php3.ini or the corresponding php3_last_modified Apache directive in which case the modification date of your script file will get sent.  Most people don't want browsers to cache old versions of dynamically generated content though.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 26 18:01:33 2024 UTC