php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68694 Uninitialized pointer read
Submitted: 2014-12-30 05:14 UTC Modified: 2015-01-08 15:51 UTC
From: bugreports at internot dot info Assigned:
Status: Closed Package: *General Issues
PHP Version: master-Git-2014-12-30 (Git) OS: Linux Ubuntu 14.04
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: bugreports at internot dot info
New email:
PHP Version: OS:

 

 [2014-12-30 05:14 UTC] bugreports at internot dot info
Description:
------------
Hi,

In /ext/standard/url_scanner_ex.re, there is an uninitialized pointer read:

 54        char *lasts;

[..]

 72        for (key = php_strtok_r(tmp, ",", &lasts);



Thanks,


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-08 08:38 UTC] laruence@php.net
Automatic comment on behalf of laruence
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f3ea1b0b6a42a08093bf9191ad76fb4b5e0a653b
Log: Fixed #68694
 [2015-01-08 08:38 UTC] laruence@php.net
-Status: Open +Status: Closed
 [2015-01-08 15:51 UTC] bugreports at internot dot info
Not a bug.
'tmp' must be NULL for this to work, which can not work, since tmp is allocated using emalloc, which does not return NULL, but exits with out-of-memory.
 [2016-07-20 11:40 UTC] davey@php.net
Automatic comment on behalf of laruence
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f3ea1b0b6a42a08093bf9191ad76fb4b5e0a653b
Log: Fixed #68694
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jun 30 19:05:47 2022 UTC