php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68693 uninitalized pointer in PDO handling
Submitted: 2014-12-30 05:06 UTC Modified: 2016-07-10 17:15 UTC
From: bugreports at internot dot info Assigned:
Status: Not a bug Package: PDO related
PHP Version: master-Git-2014-12-30 (Git) OS: Linux Ubuntu 14.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugreports at internot dot info
New email:
PHP Version: OS:

 

 [2014-12-30 05:06 UTC] bugreports at internot dot info
Description:
------------
Hi,

In /ext/pdo/pdo_sql_parser.c, an uninitalized pointer read may occur:


424        Scanner s;
[..]
440        while((t = scan(&s)) != PDO_PARSER_EOI) {

scan() will try to read s.ptr, which does not exist.


Thanks,


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-07-10 17:15 UTC] mbeccati@php.net
-Status: Open +Status: Not a bug
 [2016-07-10 17:15 UTC] mbeccati@php.net
If you look closely, such read doesn't occur in the code is generated by re2c.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Jul 19 07:01:30 2024 UTC