php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68674 Invalid free
Submitted: 2014-12-29 01:54 UTC Modified: 2015-08-08 14:03 UTC
From: bugreports at internot dot info Assigned: bwoebi (profile)
Status: Not a bug Package: phpdbg
PHP Version: master-Git-2014-12-29 (Git) OS: Linux Ubuntu 14.04
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: bugreports at internot dot info
New email:
PHP Version: OS:

 

 [2014-12-29 01:54 UTC] bugreports at internot dot info
Description:
------------
Hi,


In /sapi/phpdbg/phpdbg_bp.c:

211                                        if ((*str)[0]) {
212                                                efree(*str);

As you can see from line 211, *str is an array.

Thanks,


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-12-30 02:53 UTC] aharvey@php.net
-Package: *General Issues +Package: phpdbg
 [2015-01-08 08:34 UTC] laruence@php.net
-Assigned To: +Assigned To: krakjoe
 [2015-08-08 14:03 UTC] bwoebi@php.net
-Status: Assigned +Status: Not a bug -Assigned To: krakjoe +Assigned To: bwoebi
 [2015-08-08 14:03 UTC] bwoebi@php.net
There's no invalid free. The check is to prevent the literal "" (with which str is initialized) to be freed. Hence it checks whether the first byte is not 0.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 08:01:28 2024 UTC