php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #68459 Stable release
Submitted: 2014-11-20 09:14 UTC Modified: 2016-06-12 15:32 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: jpswade at gmail dot com Assigned: langemeijer (profile)
Status: Closed Package: ssh2 (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jpswade at gmail dot com
New email:
PHP Version: OS:

 

 [2014-11-20 09:14 UTC] jpswade at gmail dot com
Description:
------------
The ssh2 pecl extension has been around since 2005.

I've used the extension since it's inception.

There has not been an update since 2012, yet it does remain stable.

Is there any reason why this is still in beta?

Test script:
---------------
# pecl install ssh2

Expected result:
----------------
You would expect pecl install ssh2 to be stable so it will install without specifying 'beta'.

Actual result:
--------------
Failed to download pecl/ssh2 within preferred state "stable", latest release is version 0.12, stability "beta", use "channel://pecl.php.net/ssh2-0.12" to install
install failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-12 15:32 UTC] langemeijer@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: langemeijer
 [2016-06-12 15:32 UTC] langemeijer@php.net
A stable release has been made.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 16:01:25 2020 UTC