php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68442 can not restart fpm use signal -USR2
Submitted: 2014-11-18 04:05 UTC Modified: 2014-11-18 15:28 UTC
From: alloyfang at sina dot com Assigned: remi (profile)
Status: Duplicate Package: FPM related
PHP Version: 5.5.19 OS: CenetOS 6.5 x86_64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alloyfang at sina dot com
New email:
PHP Version: OS:

 

 [2014-11-18 04:05 UTC] alloyfang at sina dot com
Description:
------------
use command
kill -USR2 `cat /export/home/web/php/var/run/php-fpm.pid`
to restart fpm, fpm stop and didn't start.

php-5.5.19 restart log

[18-Nov-2014 11:32:35] NOTICE: Reloading in progress ...
[18-Nov-2014 11:32:35] NOTICE: reloading: execvp("/export/home/web/php/sbin/php-fpm", {"/export/home/web/php/sbin/php-fpm"})
[18-Nov-2014 11:32:35] NOTICE: using inherited socket fd=7, "L"
[18-Nov-2014 11:32:35] NOTICE: using inherited socket fd=7, "L"
[18-Nov-2014 11:32:35] ERROR: unable to bind listening socket for address '127.0.0.1:9000': Address already in use (98)
[18-Nov-2014 11:32:35] ERROR: unable to bind listening socket for address '127.0.0.1:9000': Address already in use (98)
[18-Nov-2014 11:32:35] ERROR: FPM initialization failed
[18-Nov-2014 11:32:35] ERROR: FPM initialization failed


It seem [fd=7, "L"] get some encode error.and it doesn't show the same when I try again.


[18-Nov-2014 11:38:09] NOTICE: using inherited socket fd=7, "Ì"
[18-Nov-2014 11:38:09] NOTICE: using inherited socket fd=7, "Ì"


I test at php-5.5.7 and it works well

php-5.5.7 restart log

[18-Nov-2014 11:25:35] NOTICE: Reloading in progress ...
[18-Nov-2014 11:25:35] NOTICE: reloading: execvp("/export/home/web/php/sbin/php-fpm", {"/export/home/web/php/sbin/php-fpm"})
[18-Nov-2014 11:25:35] NOTICE: using inherited socket fd=7, "127.0.0.1:9000"
[18-Nov-2014 11:25:35] NOTICE: using inherited socket fd=7, "127.0.0.1:9000"
[18-Nov-2014 11:25:35] NOTICE: fpm is running, pid 21790
[18-Nov-2014 11:25:35] NOTICE: ready to handle connections

Expected result:
----------------
php-fpm should restart

Actual result:
--------------
php-fpm stop and didn't start

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-11-18 08:09 UTC] remi@php.net
It seems to be related to other FPM bugs in 5.5.19 / 5.6.3

Can you please try this fix
http://git.php.net/?p=php-src.git;a=commitdiff;h=23db11976889c3600cf7853fe0fd687a1c9435e6

(tips: binary packages in remi repository for C6 includes these fix)
 [2014-11-18 10:13 UTC] remi@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: remi
 [2014-11-18 10:13 UTC] remi@php.net
Unit test added
http://git.php.net/?p=php-src.git;a=commitdiff;h=51394dff3f8d55fd40823e1841a97e631f4dfec5

Closing as duplicate of #68423
 [2014-11-18 15:28 UTC] alloyfang at sina dot com
use newest fpm_socket.c to compile php, it works. great job.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC