php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6842 Apache 1.3.12 with PHP 4.0.2 cannot handle more than 127 name based vhosts.
Submitted: 2000-09-21 22:59 UTC Modified: 2000-12-18 11:50 UTC
From: adi at tvnet dot hu Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 4.0.2 OS: Solaris 2.8 SPARC
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: adi at tvnet dot hu
New email:
PHP Version: OS:

 

 [2000-09-21 22:59 UTC] adi at tvnet dot hu
I use Solaris 2.8 (Generic_108528-01), Apache 1.3.12 and PHP 4.0.2. After adding the 128th name based virtual host, the server stops executing PHP scripts, but all other parts of the webserver remain functional. If I wanted to execute a PHP script, then the server responds that it cannot find the script ITSELF for inclusion. I reproduced the same configuration on Debian/GNU Linux 2.2 w/ kernel 2.2.17 and it went smoothly. PHP 3.0.16 produces the same results on the Sun, I haven't yet tested it on Linux (since I prefer using PHP4).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-18 11:50 UTC] sniper@php.net
You're out of filehandles. I don't know how to increase
them in Solaris..but you can check it with /usr/proc/pfiles
( man pfiles ) 

--Jani
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 26 06:01:23 2020 UTC