php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68334 Log server responses to stdout instead of stderr
Submitted: 2014-10-31 15:30 UTC Modified: 2021-10-18 15:42 UTC
Votes:6
Avg. Score:4.0 ± 1.0
Reproduced:5 of 5 (100.0%)
Same Version:1 (20.0%)
Same OS:1 (20.0%)
From: magnus dot hellman at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Built-in web server
PHP Version: 5.6.2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: magnus dot hellman at gmail dot com
New email:
PHP Version: OS:

 

 [2014-10-31 15:30 UTC] magnus dot hellman at gmail dot com
Description:
------------
Server responses are sent to stderr. They are not errors.

Test script:
---------------
touch index.php
php -S localhost:8001 > /dev/null
curl localhost:8001

Expected result:
----------------
Should be empty

Actual result:
--------------
[Fri Oct 31 16:18:01 2014] 127.0.0.1:40507 [200]: /

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-10-18 15:42 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-10-18 15:42 UTC] cmb@php.net
> Server responses are sent to stderr. They are not errors.

Right, but they are not the main output, but rather diagnostics,
and so it's fine to write them to stderr.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 26 00:03:34 2021 UTC