php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #68257 Return type defenition
Submitted: 2014-10-18 07:17 UTC Modified: 2014-10-18 07:22 UTC
From: antivir88 at mail dot ru Assigned:
Status: Not a bug Package: PHP Language Specification
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: antivir88 at mail dot ru
New email:
PHP Version: OS:

 

 [2014-10-18 07:17 UTC] antivir88 at mail dot ru
Description:
------------
Type definitions for a return value

Test script:
---------------
bool public function someFunction(array $params=[]) {
   return true;
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-10-18 07:22 UTC] stas@php.net
-Status: Open +Status: Not a bug
 [2014-10-18 07:22 UTC] stas@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Standards describe current language behavior. To propose new language feature, the correct process is RFC (see wiki.php.net/rfc) and internals mailing list discussion. Please also see this RFC: https://wiki.php.net/rfc/returntypehinting
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 18 20:03:33 2021 UTC