|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6821 Segmentation fault when opening a php test page
Submitted: 2000-09-20 21:56 UTC Modified: 2001-02-20 07:58 UTC
From: mb38 at onyx dot net Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.2 OS: AIX 4.3.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: mb38 at onyx dot net
New email:
PHP Version: OS:


 [2000-09-20 21:56 UTC] mb38 at onyx dot net
Building php with...

./configure --with-apxs=/usr/local/apache/bin/apxs \
--with-config-file-path=/server/httpd/conf \
--enable-c9x-inline \
--without-mysql \
--enable-shared=all \

with ORACLE_HOME correctly set. I Have Apache 1.3.12 compiled with:

/usr/vac/bin/cc -qlibansi -qansialias -lpthread

php is built with the same compiler/options

Compiles ok and apache starts ok. The header in the log states php 4.0.2 is loaded.

I have a test page...


When I try to load the page in a browser the apache instance seg faults.

I have built php exactly the same but minus the oci8 support and it works fine.

Any answers.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2000-09-21 18:07 UTC] mb38 at onyx dot net
Output from dbx is as follows

# dbx -I src httpd core
Type 'help' for help.
reading symbolic information ...
[using memory image in core]

Segmentation fault in sig_coredump at line 2742 in file "src/http_main.c"
"http_main.c" has only 2558 lines
(dbx) where
sig_coredump(sig = 11), line 2742 in "http_main.c"
alloca() at 0xd296a5ec
php_execute_script(0x2ff22730), line 1135 in "main.c"
apache_php_module_main(0x20140ff0, 0x0), line 89 in "sapi_apache.c"
send_php(0x20140ff0, 0x0, 0x20141a20), line 503 in "mod_php4.c"
send_parsed_php(0x20140ff0), line 514 in "mod_php4.c"
ap_invoke_handler(0x20140ff0), line 508 in "http_config.c"
process_request_internal(0x20140ff0), line 1215 in "http_request.c"
ap_process_request(0x20140ff0), line 1231 in "http_request.c"
unnamed block $b39, line 4177 in "http_main.c"
child_main(child_num_arg = 0), line 4177 in "http_main.c"
make_child(s = 0x2001e290, slot = 0, now = 969550169), line 4336 in "http_main.c
startup_children(number_to_start = 5), line 4363 in "http_main.c"
standalone_main(argc = 3, argv = 0x2ff22be0), line 4651 in "http_main.c"
http_main.main(argc = 3, argv = 0x2ff22be0), line 4978 in "http_main.c"

If this adds anything to the case.

 [2000-09-27 17:57 UTC] mb38 at onyx dot net
Awaiting feedback on this bug report!
 [2001-01-07 19:44 UTC]
Does this happen with PHP 4.0.4 ? 
Or with latest snapshot from ??

 [2001-01-10 04:18 UTC] mb38 at onyx dot net
Haven't tried a newer version of PHP. What exactly would be the point of this exercise? Is there a specific change or area of change in the later versions that could have an influence? If not then trying a newer version won't reveal anything about the problem.

I haven't tried the snapshot either. To be honest I don't know what a snapshot is. I've searched the php site for info about snapshots and trawled through the FAQ. I've even searched the Zend site. There's nothing to be found. In the absence of info I don't want to waste my time downloading something that I know nothing about.

 [2001-01-10 07:41 UTC]
There have been a lots of fixes in both PHP and Zend after 4.0.2 was released.

Another thing, did you set the environment variables (for Oracle) before starting
apache? Please check:


 [2001-02-20 07:58 UTC]
No feedback, considered fixed.


PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Mar 28 16:20:31 2023 UTC