php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68192 Compile fails with "undefined reference to `__extendsfsd'"
Submitted: 2014-10-08 21:35 UTC Modified: 2014-10-08 22:41 UTC
From: php at wesha dot name Assigned:
Status: Duplicate Package: Compile Failure
PHP Version: 5.6.1 OS: FreeBSD 8.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: php at wesha dot name
New email:
PHP Version: OS:

 

 [2014-10-08 21:35 UTC] php at wesha dot name
Description:
------------
Error message when attempting 'make':

ext/mysqlnd/.libs/mysqlnd_ps_codec.o(.text+0xaaa): In function `ps_fetch_float':
/root/_build/php/php-5.6.1/ext/mysqlnd/mysqlnd_ps_codec.c:233: undefined reference to `__extendsfsd'
ext/mysqlnd/.libs/mysqlnd_ps_codec.o(.text+0xab5):/root/_build/php/php-5.6.1/ext/mysqlnd/mysqlnd_ps_codec.c:233: undefined reference to `__extendsddf'
gmake: *** [sapi/cli/php] Error 1


Please note that 5.6.0 compiled just fine.

Test script:
---------------
Configure options:
--with-mysql=/usr/local
--with-mysqli=mysqlnd
--with-gd
--with-apxs2=/usr/local/apache2/bin/apxs
--with-zlib
--enable-gd-native-ttf
--with-freetype-dir=/usr/local/lib
--with-jpeg-dir=/usr/local/lib
--with-openssl
--with-iconv
--enable-mbstring
--enable-sockets
--enable-pcntl
--with-mcrypt
--with-pdo-mysql
--with-bz2
--enable-zip
--with-curl



Patches

--with-pdo-mysql (last revision 2016-09-27 08:00 UTC by sem at advancedhosters dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-10-08 22:41 UTC] leigh@php.net
-Status: Open +Status: Duplicate
 [2014-10-08 22:41 UTC] leigh@php.net
This error is a duplicate of the one reported in: https://bugs.php.net/bug.php?id=68114

Could you please try the fix from the previous bug report, and make any further feedback in that report instead.

Thanks for taking the time to report this, and for supporting PHP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Sep 17 00:01:27 2019 UTC