php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68080 ... operator causes a segmentation fault
Submitted: 2014-09-22 21:11 UTC Modified: 2014-09-22 21:14 UTC
From: v dot guth at owlient dot eu Assigned:
Status: Duplicate Package: Reproducible crash
PHP Version: master-Git-2014-09-22 (Git) OS: Ubuntu 14.04
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: v dot guth at owlient dot eu
New email:
PHP Version: OS:

 

 [2014-09-22 21:11 UTC] v dot guth at owlient dot eu
Description:
------------
This PHP code generates a segmentation fault.

I would expect an error message such as :
Fatal error: Declaration of B::c() must be compatible with A::c() in /tmp/test.php on line 13


Test script:
---------------
<?php
abstract class A {
	
	abstract public function c();
	
}

class B extends A {
	
	public function c(...$list) {
	}
	
}
?>

Expected result:
----------------
A nice error message:

Fatal error: Declaration of B::c() must be compatible with A::c() in /tmp/test.php on line 13

Actual result:
--------------
A segmentation fault:

vincent@abricow:/var/www$ php /tmp/test.php 
Erreur de segmentation (core dumped)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-09-22 21:14 UTC] v dot guth at owlient dot eu
<?php
class A {
	
	public function c() {
		
	}
	
}

class B extends A {
	
	public function c(...$list) {
	}
	
}
?>

... does not work either.
 [2014-09-22 21:14 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2014-09-22 21:14 UTC] nikic@php.net
Duplicate of https://bugs.php.net/bug.php?id=67938. This will be fixed in 5.6.1.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 22 09:01:23 2020 UTC