php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68070 Wrong Answer to a fairly standard calculation
Submitted: 2014-09-22 10:10 UTC Modified: 2014-09-22 10:13 UTC
From: elliot at essentialsystems dot co dot uk Assigned:
Status: Not a bug Package: Math related
PHP Version: Irrelevant OS: Ubuntu
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: elliot at essentialsystems dot co dot uk
New email:
PHP Version: OS:

 

 [2014-09-22 10:10 UTC] elliot at essentialsystems dot co dot uk
Description:
------------
The calculation in the test script should return 34, but yet is returning back 33.999999999998, which is very odd.

Test script:
---------------
<?php
//expecting 34
var_dump((40120.7 - 36346.0)-3740.7);
?>

Expected result:
----------------
Return back of the value of 34.

Actual result:
--------------
33.999999999998

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-09-22 10:13 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2014-09-22 10:13 UTC] nikic@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 19 18:01:29 2020 UTC