php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #68045 Anchor tagets disappear below fixed header
Submitted: 2014-09-18 14:07 UTC Modified: 2014-09-18 14:16 UTC
From: sebastian dot leitz at etes dot de Assigned:
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sebastian dot leitz at etes dot de
New email:
PHP Version: OS:

 

 [2014-09-18 14:07 UTC] sebastian dot leitz at etes dot de
Description:
------------
If you open links like http://php.net/ChangeLog-5.php#5.5.17 (which are commonly included in release notes) or http://de2.php.net/strpos#refsect1-function.strpos-examples (to reference parts of a doc page), the anchor target is always a heading which will not be visible.

The headline is hidden because the header of php.net uses "position: fixed" and thus is always present.

This is a very common problem, so you can easily find solutions which make sure that the headline will stay visible (by jumping not to the heading itself but to a place e.g. 40px before that).

Some hints:

- http://stackoverflow.com/questions/4086107/html-positionfixed-page-header-and-in-page-anchors
- http://stackoverflow.com/questions/10732690/offsetting-an-html-anchor-to-adjust-for-fixed-header


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-09-18 14:16 UTC] sobak@php.net
-Status: Open +Status: Duplicate
 [2014-09-18 14:16 UTC] sobak@php.net
Duplicate of bug #67050
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 18 16:01:23 2020 UTC