php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68030 PHP master makes Apache 2.4.10 x64 restart
Submitted: 2014-09-16 18:25 UTC Modified: 2014-09-18 15:21 UTC
From: jfha73 at gmail dot com Assigned: ab (profile)
Status: Closed Package: Apache2 related
PHP Version: master-Git-2014-09-16 (Git) OS: Windows x64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jfha73 at gmail dot com
New email:
PHP Version: OS:

 

 [2014-09-16 18:25 UTC] jfha73 at gmail dot com
Description:
------------
Hey guys,

I just cloned your latest master, compiled it and tried it with my Apache 2.4.10 x64 for Windows and it makes it restart all by itself, I don't get anything in the error log other than the server stopped and restarted.

Test script:
---------------
phpinfo();

Expected result:
----------------
Show me phpinfo();

Actual result:
--------------
I get a 404 because Apache stops

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-09-16 18:29 UTC] jfha73 at gmail dot com
This is what I used to compile it (added uploadprogress to test with a pecl):

configure --enable-apache2-4handler --with-bz2=shared --with-curl=shared --with-dba=shared --with-enchant=shared --enable-fileinfo=shared --with-gettext=shared --with-gmp=shared --with-mhash=shared --with-imap=shared --enable-intl=shared --with-ldap=shared --enable-mbstring=shared --enable-mbregex=shared --with-mcrypt=shared --with-openssl=shared --with-pgsql=shared --enable-shmop=shared --with-snmp=shared --enable-sockets=shared --with-tidy=shared --enable-uploadprogress=shared --enable-exif=shared --with-mysql=shared --with-mysqli=shared --enable-pdo=shared --with-pdo-mysql=shared --with-pdo-pgsql=shared --enable-soap=shared --with-xmlrpc=shared --with-xsl=shared

I can run "php -m" with no problems and "httpd -t" says Syntax is OK I can also run my info.php using CLI, just not in Apache.
 [2014-09-18 15:21 UTC] ab@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ab
 [2014-09-18 15:21 UTC] ab@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 14:03:37 2021 UTC