php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #68007 Clearing the APC cache from CLI
Submitted: 2014-09-11 13:49 UTC Modified: 2014-09-15 06:00 UTC
From: php at maximilianb dot de Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at maximilianb dot de
New email:
PHP Version: OS:

 

 [2014-09-11 13:49 UTC] php at maximilianb dot de
Description:
------------
As mentioned in one of the user comments you have to send an HTTP request to clear all of the caches. If you call apc_clear_cache() from the CLI only the CLI cache will be cleared.

I think this is an essential information and should mentioned in the manual itself rather than only in a comment.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-09-15 06:00 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2014-09-15 06:00 UTC] krakjoe@php.net
That seems extremely obvious, it couldn't possibly behave another way.

So I think we'll pass on including a message about this one particular functions behaviour, and continue to let it be obvious that distinct processes have distinct caches.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Apr 23 08:01:24 2021 UTC