php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67999 function imagewebp doesn't exist in PHP 5.6
Submitted: 2014-09-10 14:23 UTC Modified: 2015-07-11 21:32 UTC
Votes:5
Avg. Score:4.2 ± 0.7
Reproduced:5 of 5 (100.0%)
Same Version:5 (100.0%)
Same OS:2 (40.0%)
From: alfred dot bez at googlemail dot com Assigned: szarkos (profile)
Status: Closed Package: GD related
PHP Version: 5.6.0 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alfred dot bez at googlemail dot com
New email:
PHP Version: OS:

 

 [2014-09-10 14:23 UTC] alfred dot bez at googlemail dot com
Description:
------------
The function "imagewebp" doesn't exist in PHP 5.6, but it should be enabled since 5.5.0 .

Test script:
---------------
<?php
echo phpversion();
echo "\n";
var_dump(function_exists('imagewebp'));

Expected result:
----------------
5.6.0
bool(false)

Actual result:
--------------
5.6.0RC2
bool(true)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-09-10 14:28 UTC] alfred dot bez at googlemail dot com
I've mistaken the actual result and the expected result.
 [2014-09-10 15:00 UTC] alfred dot bez at gmail dot com
see also: http://stackoverflow.com/questions/25767308/function-imagewebp-doesnt-exist-in-php-5-6
 [2014-09-10 15:32 UTC] pajoye@php.net
-Assigned To: +Assigned To: szarkos
 [2014-09-10 15:32 UTC] pajoye@php.net
Looks like The build went wrong, Steve can you look at it for 5.6.1 pls?
 [2015-07-11 21:32 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2015-07-11 21:32 UTC] cmb@php.net
It's not clear to me whether this report is Windows specific. If
so, latest PHP 5.6.x does have support for WebP enabled.
Otherwise, when compiling from the sources on other OS the
--with-vpx-dir= option has to be passed to configure.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 08:03:36 2021 UTC