php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67963 display language not set properly
Submitted: 2014-09-05 09:14 UTC Modified: 2014-09-05 20:04 UTC
From: piotr at mierski dot pl Assigned:
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: piotr at mierski dot pl
New email:
PHP Version: OS:

 

 [2014-09-05 09:14 UTC] piotr at mierski dot pl
Description:
------------
---
From manual page: http://www.php.net/function.file-exists
---

Language select box does not reflect the display language tough it makes it impossible to switch back to english version. For instance please visit:

http://php.net/manual/pl/function.file-exists.php

You'll see a page displayed in polish language but since language selectbox is not set to `polish` or `other` it's impossible to change the display language to english. So you need to either include the current display language option with selected attrib on it or just mark the `other` option as selected.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-09-05 13:59 UTC] bjori@php.net
-Status: Open +Status: Verified
 [2014-09-05 13:59 UTC] bjori@php.net
Its because polish isn't a supported language, so that box think this page is in english.
 [2014-09-05 19:20 UTC] piotr at mierski dot pl
An that's a bug which makes it impossible to switch to english. You should make the `other` option selected to allow people to switch to english language.
 [2014-09-05 20:04 UTC] sobak@php.net
-Status: Verified +Status: Duplicate
 [2014-09-05 20:04 UTC] sobak@php.net
I would rather mark this report as a duplicate of bug #67629

By the way, Piotr, I have spent many hours on updating Polish translation and hopefully it will be moved to active languages in a month or so. Of course this won't fix reported bug (just resolve this particular case), but I think you might be interested :)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 17 21:01:24 2020 UTC