php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67876 output invalid
Submitted: 2014-08-21 04:15 UTC Modified: 2014-08-21 05:19 UTC
From: jaikeysarraf at gmail dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.5.15 OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jaikeysarraf at gmail dot com
New email:
PHP Version: OS:

 

 [2014-08-21 04:15 UTC] jaikeysarraf at gmail dot com
Description:
------------
here is my simple code : 
<?php
   $a=07;
   $b=08;
   if ($a>$b)
   {
     echo $a;
     }
     else {
       echo $b;
     }
?>

this should output 8
but shows me 7 

I don't know why but in other languages(java vb) answer is always 8 

Test script:
---------------
<?php
   $a=07;
   $b=08;
   if ($a>$b)
   {
     echo $a;
     }
     else {
       echo $b;
     }
?>

Expected result:
----------------
should be 8 in output

Actual result:
--------------
7

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-08-21 05:19 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2014-08-21 05:19 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Zero prefix on a number means octal. 08 is invalid octal so $b is 0.
http://php.net/manual/en/language.types.integer.php
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Sep 27 21:05:53 2022 UTC