php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6786 PHP stability problem w/ mssql70.dll loaded
Submitted: 2000-09-17 05:57 UTC Modified: 2000-10-20 17:18 UTC
From: andy at Mindgate dot net Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.2 OS: NT 5/Win 2K
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andy at Mindgate dot net
New email:
PHP Version: OS:

 

 [2000-09-17 05:57 UTC] andy at Mindgate dot net
Even simple scripts like the one below *WITHOUT AN MSSQL QUERY* when reloaded repeatedly quickly will either cause an access violation error or make php get stuck (i.e. CPU meter will show cycles being consumed even though all pages have finished loading - note: I am using dual processor under Win 2000 Pro).  The only changes to the php.ini-optimized file were register_globals=On, magic_quotes_gpc=on and extension=php_mssql70.dll

Simply loading php_mssql70.dll seems to be the culprit as without it the phenomena does not occur. This is probably the cause of the other reported MS SQL bugs as well and seems to have nothing to do with running a database query at all.


<html>
<body>
<?php
if ($pic!="off") {
	print "
<A HREF='testing.php?site=".$site."&pic=off&aud=".$aud."&dwg=".$dwg."&txt=".$txt."'>
	<IMG NAME='turf_vault_05' SRC='images/turf-vault_05-over.gif' WIDTH=40 HEIGHT=31 BORDER=0></A>"; 
} else {
	print "
<A HREF='testing.php?site=".$site."&pic=on&aud=".$aud."&dwg=".$dwg."&txt=".$txt."'>
	<IMG NAME='turf_vault_05' SRC='images/turf-vault_05.gif' WIDTH=40 HEIGHT=31 BORDER=0></A>"; 
}
if ($aud!="off") {
	print "
<A HREF='testing.php?site=".$site."&pic=".$pic."&aud=off&dwg=".$dwg."&txt=".$txt."'>
	<IMG NAME='turf_vault_09' SRC='images/turf-vault_09-over.gif' WIDTH=35 HEIGHT=33 BORDER=0></A>"; 
} else {
	print "
<A HREF='testing.php?site=".$site."&pic=".$pic."&aud=on&dwg=".$dwg."&txt=".$txt."'>
	<IMG NAME='turf_vault_09' SRC='images/turf-vault_09.gif' WIDTH=35 HEIGHT=33 BORDER=0></A>"; 
}
if ($txt!="off") {
	print "
<A HREF='testing.php?site=".$site."&pic=".$pic."&aud=".$aud."&dwg=".$dwg."&txt=off'>
	<IMG NAME='turf_vault_17' SRC='images/turf-vault_17-over.gif' WIDTH=37 HEIGHT=36 BORDER=0></A>"; 
} else {
	print "
<A HREF='testing.php?site=".$site."&pic=".$pic."&aud=".$aud."&dwg=".$dwg."&txt=on'>
	<IMG NAME='turf_vault_17' SRC='images/turf-vault_17.gif' WIDTH=37 HEIGHT=36 BORDER=0></A>"; 
}
?>
	</body>
</html>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-20 17:18 UTC] fmk@php.net
Some memory issues was fixed in the module released with php 4.0.3.

Please update an try again.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jun 28 18:05:44 2022 UTC