php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #67728 Support PCRE JIT compilation in PCRE extension
Submitted: 2014-07-31 15:32 UTC Modified: 2015-03-15 08:19 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: totallynotvalid at maildrop dot cc Assigned: nikic (profile)
Status: Closed Package: PCRE related
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: totallynotvalid at maildrop dot cc
New email:
PHP Version: OS:

 

 [2014-07-31 15:32 UTC] totallynotvalid at maildrop dot cc
Description:
------------
Hello,
Based on benchmarks with PCRE JIT (http://sljit.sourceforge.net/pcre.html), it seems PHP could benefit from having the PCRE extension built with support for JIT. Mediawiki in particular and other large frameworks that do a lot of parsing with regular expressions could see significant performance improvements with PCRE JIT support.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-03 00:50 UTC] reeze@php.net
-Status: Open +Status: Feedback
 [2015-03-03 00:50 UTC] reeze@php.net
Please try using this snapshot:

  http://snaps.php.net/php-trunk-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2015-03-15 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2015-03-15 08:19 UTC] nikic@php.net
-Status: No Feedback +Status: Closed -Assigned To: +Assigned To: nikic
 [2015-03-15 08:19 UTC] nikic@php.net
PHP 7 uses PCRE JIT.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 10:03:36 2021 UTC