php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67670 Segfault when starting php-fpm
Submitted: 2014-07-23 09:10 UTC Modified: 2014-07-23 09:29 UTC
From: ryan at rmauger dot co dot uk Assigned:
Status: Closed Package: FPM related
PHP Version: 5.5.14 OS: Debian Wheezy
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
42 - 21 = ?
Subscribe to this entry?

 
 [2014-07-23 09:10 UTC] ryan at rmauger dot co dot uk
Description:
------------
After compiling php-fpm from source on debian, a segfault is encountered when starting php-fpm.

Test script:
---------------
configure and make php as normal,
run make install
restart php-fpm with 'service php-fpm restrart'


The configure command used was:
./configure --with-config-file-path=/etc/php/fpm --with-config-file-scan-dir=/etc/php/fpm/conf.d --sysconfdir=/etc/php --disable-cli --disable-cgi --enable-fpm --with-pdo-mysql=mysqlnd --with-mysqli=mysqlnd --with-curl --enable-zip --with-zlib=/usr --with-tidy --with-openssl --with-mcrypt --enable-soap --with-iconv --enable-mbstring --enable-intl --with-gd --enable-gd-native-ttf --with-jpeg-dir=/usr/lib --with-imagick --enable-opcache




Actual result:
--------------
GNU gdb (GDB) 7.4.1-debian
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/local/sbin/php-fpm...done.
warning: not using untrusted file ".gdbinit"
(gdb) run
Starting program: /usr/local/sbin/php-fpm 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
zend_hash_merge_ex (target=target@entry=0x120da50, source=0xd0, pCopyConstructor=0x820100 <zval_add_ref>, size=size@entry=8, pMergeSource=pMergeSource@entry=0x7fd2c0 <do_inherit_constant_check>, pParam=0x0)
    at /usr/local/src/php/php-5.5.14-fpm/Zend/zend_hash.c:890
890		p = source->pListHead;
(gdb) bt
#0  zend_hash_merge_ex (target=target@entry=0x120da50, source=0xd0, pCopyConstructor=0x820100 <zval_add_ref>, size=size@entry=8, pMergeSource=pMergeSource@entry=0x7fd2c0 <do_inherit_constant_check>, pParam=0x0)
    at /usr/local/src/php/php-5.5.14-fpm/Zend/zend_hash.c:890
#1  0x0000000000803fa6 in zend_do_implement_interface (ce=ce@entry=0x120d980, iface=0x0) at /usr/local/src/php/php-5.5.14-fpm/Zend/zend_compile.c:3781
#2  0x0000000000828981 in zend_class_implements (class_entry=0x120d980, num_interfaces=<optimized out>, num_interfaces@entry=2) at /usr/local/src/php/php-5.5.14-fpm/Zend/zend_API.c:2554
#3  0x00000000005cfc86 in zm_startup_imagick (type=<optimized out>, module_number=17) at /usr/local/src/php/php-5.5.14-fpm/ext/imagick/imagick.c:2938
#4  0x0000000000823056 in zend_startup_module_ex (module=0x1113ca0) at /usr/local/src/php/php-5.5.14-fpm/Zend/zend_API.c:1759
#5  zend_startup_module_ex (module=0x1113ca0) at /usr/local/src/php/php-5.5.14-fpm/Zend/zend_API.c:1713
#6  0x000000000082f535 in zend_hash_apply (ht=ht@entry=0x10de680, apply_func=apply_func@entry=0x822f60 <zend_startup_module_ex>) at /usr/local/src/php/php-5.5.14-fpm/Zend/zend_hash.c:716
#7  0x0000000000826f5a in zend_startup_modules () at /usr/local/src/php/php-5.5.14-fpm/Zend/zend_API.c:1886
#8  0x00000000007c0d9e in php_module_startup (sf=<optimized out>, additional_modules=additional_modules@entry=0x10b94e0, num_additional_modules=num_additional_modules@entry=1)
    at /usr/local/src/php/php-5.5.14-fpm/main/main.c:2229
#9  0x00000000008dafe5 in php_cgi_startup (sapi_module=<optimized out>) at /usr/local/src/php/php-5.5.14-fpm/sapi/fpm/fpm/fpm_main.c:856
#10 0x00000000004509f5 in main (argc=1, argv=0x7fffffffe738) at /usr/local/src/php/php-5.5.14-fpm/sapi/fpm/fpm/fpm_main.c:1776

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-07-23 09:29 UTC] ryan at rmauger dot co dot uk
-Status: Open +Status: Closed
 [2014-07-23 09:29 UTC] ryan at rmauger dot co dot uk
Have just realised this is not a bug in php, but in the imagick extension, will open ticket on their github.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 19 23:05:44 2022 UTC