php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67658 configure does not detect missing pcre.h
Submitted: 2014-07-21 07:57 UTC Modified: 2021-11-26 16:59 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: cweiske@php.net Assigned: cmb (profile)
Status: Closed Package: *General Issues
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: cweiske@php.net
New email:
PHP Version: OS:

 

 [2014-07-21 07:57 UTC] cweiske@php.net
Description:
------------
pecl/oauth's phpize and configure ran without problems, but "make" failed because pcre.h was missing. I had to install libpcre3-dev to get it working (debian) 

configure should detect that pcre.h is missing.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-07-24 15:19 UTC] jawed@php.net
Automatic comment from SVN on behalf of jawed
Revision: http://svn.php.net/viewvc/?view=revision&revision=334377
Log: Bug #67658 (configure does not detect missing pcre.h)
 [2014-07-24 15:26 UTC] jawed@php.net
Automatic comment from SVN on behalf of jawed
Revision: http://svn.php.net/viewvc/?view=revision&revision=334378
Log: Bug 67658, adding fail statement for header check
 [2014-07-24 15:26 UTC] jawed@php.net
Added the header check, can you try trunk?
 [2014-07-24 20:06 UTC] cweiske@php.net
- I get an error message with ./configure when pcre.h is not installed
- No error when it is installed. 

SVN works fine.
 [2014-07-27 08:17 UTC] remi@php.net
oauth doesn't includes pcre.h, so doesn't need to check for this header.

So I think this rev 334377 and 334378 should be reverted.


Deeper explanation:
oauth includes ext/pcre/php_pcre.h (from php extension)
php_cre.h includes 
- pcre.h when build with system pcre
OR
- pcrelib/pcre.h (from php).

I rather think this is a bug in your php distribution. Linux distro usually use system pcre, so the php-devel package MUST have a dependency on pcre-devel.
 [2014-08-01 08:24 UTC] ondrej@php.net
libpcre3-dev added as dependency of php5-dev in the debian git packaging, it will be fixed as part of next release.
 [2021-07-07 15:19 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2021-07-07 15:19 UTC] cmb@php.net
So, can I assume this ticket is obsolete?
 [2021-07-18 04:22 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2021-11-26 16:44 UTC] php-bugs-2021 at ryandesign dot com
Please revert the change for the reasons explained in remi's 2014 comment, and for the additional reason that, as of php 7.3, php's pcre functionality uses pcre2 not pcre, so now php-oauth's configure process erroneously complains about pcre.h being missing with php 7.3 and later even when the pcre2.h it actually uses is present.
 [2021-11-26 16:59 UTC] cmb@php.net
-Status: No Feedback +Status: Closed -Package: oauth +Package: *General Issues
 [2021-11-26 16:59 UTC] cmb@php.net
It is almost never a good idea to comment on a ticket which has
been addressed many years ago.  Anyhow, there is already a
respective pull request[1].

[1] <https://github.com/php/pecl-web_services-oauth/pull/18>
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Oct 03 15:04:13 2022 UTC