php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67588 configure fails to recognize systemd in CentOS 7.0
Submitted: 2014-07-08 00:23 UTC Modified: 2014-07-08 01:37 UTC
From: ck+php dot net at bbshowcase dot org Assigned:
Status: Closed Package: FPM related
PHP Version: 5.6.0RC2 OS: CentOS 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
19 - 1 = ?
Subscribe to this entry?

 
 [2014-07-08 00:23 UTC] ck+php dot net at bbshowcase dot org
Description:
------------
configure fails to recognize systemd in CentOS 7.0 GA

configure --with-fpm-systemd

configure: error: Your system does not support systemd.






Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-07-08 00:25 UTC] ck+php dot net at bbshowcase dot org
More complete result:

checking for sd_notify in -lsystemd-daemon... no
checking systemd/sd-daemon.h usability... no
checking systemd/sd-daemon.h presence... no
checking for systemd/sd-daemon.h... no
configure: error: Your system does not support systemd.
 [2014-07-08 01:14 UTC] aharvey@php.net
-Status: Open +Status: Feedback
 [2014-07-08 01:14 UTC] aharvey@php.net
Did you install the systemd-devel package?
 [2014-07-08 01:37 UTC] ck+php dot net at bbshowcase dot org
-Status: Feedback +Status: Closed
 [2014-07-08 01:37 UTC] ck+php dot net at bbshowcase dot org
Closing ticket, apologies for wasting any time over this.

Not a bug, requires systemd-devel installed (thanks aharvey)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 04:05:45 2022 UTC