|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67524 shmop_delete doesn´t work
Submitted: 2014-06-26 18:56 UTC Modified: 2018-09-18 17:01 UTC
Avg. Score:3.0 ± 2.0
Reproduced:1 of 2 (50.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: very-hot at gmx dot at Assigned: cmb (profile)
Status: Duplicate Package: *Extensibility Functions
PHP Version: 5.5.13 OS: Win 8.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: very-hot at gmx dot at
New email:
PHP Version: OS:


 [2014-06-26 18:56 UTC] very-hot at gmx dot at
I think, still doesn´t work.

See also:

Win 8.1
Apache 2.4
PHP 5.5.11

shmop_delete returns true, but the same block can be reopened on the next request.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-20 21:56 UTC] php at maisqi dot com
I found the same problem on Windows 8.1 (I got it to work under Linux). I tried PHP 5.6.3 running as FastCGI under Apache 2.4 or PHP 5.5.19 running as a Apache 2.4 module, and in both cases shmop_delete() does not free the shared memory block.
 [2016-10-07 13:06 UTC]
-Package: Unknown/Other Function +Package: *Extensibility Functions
 [2018-09-18 17:01 UTC]
Duplicate of bug #65987.
 [2018-09-18 17:01 UTC]
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 09 14:03:49 2022 UTC