php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67458 website steals shortcut for quick find in firefox
Submitted: 2014-06-17 06:44 UTC Modified: 2015-02-16 13:33 UTC
Votes:18
Avg. Score:4.2 ± 1.2
Reproduced:15 of 17 (88.2%)
Same Version:6 (40.0%)
Same OS:5 (33.3%)
From: martin dot idealia at gmx dot com Assigned:
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: martin dot idealia at gmx dot com
New email:
PHP Version: OS:

 

 [2014-06-17 06:44 UTC] martin dot idealia at gmx dot com
Description:
------------
When viewing documentation in firefox, pressing / (forward slash key) should start quick search function of firefox, instead the search input at the top right corner of the page gets focus.

Expected result:
----------------
pressing / key should start quick search in current document

Actual result:
--------------
/ press is stolen by search intpu field at the top right corner of the page

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-06-17 15:14 UTC] levim@php.net
-Status: Open +Status: Verified
 [2014-06-17 15:14 UTC] levim@php.net
I understand your pain. I understand that other websites also use this hotkey for search (for instance, twitter and gmail). I'll think about this for a while.
 [2014-07-05 12:25 UTC] sandeepcr2 at gmail dot com
Yes, gmail and twitter may have done so. But I think this function, in the context of php.net documentation pages, does more harm than good. 

Take the example of gmail. There is not much use for searching the text that is in page. Because the contents are short. Most often you are interested in the searching the mails themselves rather than the page contents.

But take the case of the php.net. The user has probably done the search in google and arrived at the exact documentation page in php.net. Now this page can have a lot of content. For eg, take the documentation page for cURL extension. There are a lot of flags and options in those pages. So there is a lot of content in the page itself and with out text search it will be hard to find the info user is looking for. So most of the time, the user will have to use the in-page-text search, as opposed to the actual site search. This issue is worsened by the fact that you cannot search for flag constants from the php.net's search function.

So I think the slash key should be returned to its default text search function by which it will be most useful.
 [2014-07-05 16:40 UTC] bjori@php.net
-Status: Verified +Status: Wont fix
 [2014-07-05 16:40 UTC] bjori@php.net
No. Use a Greasemonkey script to unbind it.
I'd recommend loading it globally so you don't have to worry about other websites using it.
 [2014-07-06 15:12 UTC] hdfssk at gmail dot com
Respectfully, Hannes, “No” should not be the last word on this subject; the / keybinding breaks the search-in-page muscle memory for firefox, for an unclear gain… how does it help wrt searching the PHP docs?

(PS. I’d much rather have voted on an open bug and moved on than tried to revive a WONTFIX this way…)
 [2015-02-16 01:53 UTC] malinky at yopmail dot com
Lack of respect for users -- bjori@php.net

What makes you think it's ok to waste the world's time - the time they spent typing in a search string, only to discover they were typing it into the php.net search box
 [2015-02-16 13:33 UTC] tularis@php.net
-Status: Wont fix +Status: Not a bug
 [2015-02-16 13:33 UTC] tularis@php.net
Well, using the latest nightly branch the / quicksearch shortcut is not 'stolen', so I guess the bug is fixed for you then.

Now, as we can see, this won't ever be 'fixed' from the side of the PHP.net website, since it's not considered a bug, but rather a feature. So let's leave it at that.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 22:03:34 2022 UTC