php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #67443 disk_total_space
Submitted: 2014-06-14 20:18 UTC Modified: 2014-06-15 03:22 UTC
From: cybermerlin at ya dot ru Assigned:
Status: Not a bug Package: Directory function related
PHP Version: 5.4.29 OS: freebsd 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cybermerlin at ya dot ru
New email:
PHP Version: OS:

 

 [2014-06-14 20:18 UTC] cybermerlin at ya dot ru
Description:
------------
---
From manual page: http://www.php.net/function.disk-total-space
---
disk_total_space('/var/www/site.com') // 38895.4Mb
disk_total_space('/var/www/site.com/folder1') // 38895.4Mb
disk_total_space('/var/www/site.com/other') // 38895.4Mb

Test script:
---------------
echo disk_total_space('/var/www/site.com'); // 38895.4Mb
echo disk_total_space('/var/www/site.com/folder1'); // 38895.4Mb
echo disk_total_space('/var/www/site.com/other'); // 38895.4Mb


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-06-15 03:22 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2014-06-15 03:22 UTC] aharvey@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 [2014-06-15 05:59 UTC] sobak@php.net
Basically, this function returns total space on DISK, not in directory. So all of your examples refers to /var/ actually, if /var/ is partition. That's why results are the same.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Sep 28 12:01:23 2020 UTC