php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67435 GmagickPixel::getColorvalue(\Gmagick::COLOR_BLACK) always returns 0
Submitted: 2014-06-13 09:08 UTC Modified: 2016-01-10 04:22 UTC
From: imprec at gmail dot com Assigned:
Status: No Feedback Package: gmagick (PECL)
PHP Version: Irrelevant OS: OSX
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: imprec at gmail dot com
New email:
PHP Version: OS:

 

 [2014-06-13 09:08 UTC] imprec at gmail dot com
Description:
------------
In a CMYK colorspace, using GmagickPixel::getColorvalue(\Gmagick::COLOR_BLACK) always returns 0 whereas the value could be different.

This behavior only appears with the \Gmagick::COLOR_BLACK component in CMYK colorspace.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-12-31 20:14 UTC] danack@php.net
-Status: Open +Status: Feedback
 [2015-12-31 20:14 UTC] danack@php.net
Pixels created by `new GmagickPixel()` are in RGB colorspace by default. There does not appear to be a way of setting CMYK colors in GraphicsMagick.

Please post a sample script if you think you have a CMYK pixel that is showing the wrong behaviour.
 [2016-01-10 04:22 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 03:01:36 2019 UTC