php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67417 ::compress modifies archive basename.
Submitted: 2014-06-10 15:52 UTC Modified: 2015-03-30 18:49 UTC
From: pajoye@php.net Assigned:
Status: Duplicate Package: PHAR related
PHP Version: Irrelevant OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pajoye@php.net
New email:
PHP Version: OS:

 

 [2014-06-10 15:52 UTC] pajoye@php.net
Description:
------------
::compress modifies archive basename.

Test script:
---------------
<?php
$files = ['a.txt'];

$arch = new \PharData('foo-1.2.3.tar');
foreach ($files as $file) {
	$arch->addFile($file);
}
$arch->compress(\Phar::GZ);


Expected result:
----------------
foo-1.2.3.tar.gz

Actual result:
--------------
foo-1.tar.gz

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-30 18:49 UTC] mike@php.net
-Status: Open +Status: Duplicate
 [2015-03-30 18:49 UTC] mike@php.net
Duplicate of Bug #60953 -- silly usage of strtok
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Feb 23 17:01:28 2020 UTC