php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6737 gettype of 'user function' returns null
Submitted: 2000-09-13 15:55 UTC Modified: 2001-05-11 19:39 UTC
From: ping at alt dot it Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 4.0.2 OS: Linux Mandrake 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ping at alt dot it
New email:
PHP Version: OS:

 

 [2000-09-13 15:55 UTC] ping at alt dot it
gettype() on function names returns null

Although undocumented, in version 3 it properly returned 'user function'.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-09-13 16:17 UTC] joey@php.net
Changing behavior of undocumented features is not a bug, sorry.
 [2000-09-13 16:21 UTC] joey@php.net
Although at second glace, it appears that this
WAS a documented behavior.

That's what I get for not double checking.
 [2000-09-16 18:22 UTC] stas@php.net
dup of #6741
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jul 13 09:01:23 2020 UTC