php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67353 Compiling failing with LDAP flag
Submitted: 2014-05-28 16:37 UTC Modified: 2014-12-30 10:42 UTC
Votes:8
Avg. Score:4.2 ± 1.0
Reproduced:8 of 8 (100.0%)
Same Version:1 (12.5%)
Same OS:1 (12.5%)
From: garrod dot alwood at gmail dot com Assigned: tyrael (profile)
Status: No Feedback Package: Compile Failure
PHP Version: 5.6.0beta3 OS: Debian 7.5.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
43 - 25 = ?
Subscribe to this entry?

 
 [2014-05-28 16:37 UTC] garrod dot alwood at gmail dot com
Description:
------------
During compiling with the --with-ldap flag the compile fails when it gets to compiling the ldap modules in debian 7.5.0.

Test script:
---------------
'./configure' '--disable-debug' '--enable-inline-optimization' '--disable-all' '--enable-libxml' '--enable-session' '--enable-xml' '--enable-hash' '--with-pear' '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-layout=GNU' '--enable-filter' '--with-pcre-regex' '--with-zlib' '--enable-simplexml' '--enable-xmlwriter' '--enable-dom' '--with-openssl=/usr/local/ssl/' '--enable-pdo' '--with-pdo-sqlite' '--with-readline' '--with-sqlite3' '--disable-phar' '--with-libedit' '--enable-exif' '--with-bz2' '--with-gettext' '--with-mcrypt' '--with-mhash' '--with-gd' '--with-jpeg-dir' '--with-png-dir' '--with-zlib-dir' '--with-xpm-dir' '--with-xsl' '--with-tidy' '--with-freetype-dir' '--enable-gd-native-ttf' '--enable-mbstring' '--enable-sockets' '--enable-dom' '--enable-xml' '--enable-soap' '--enable-libxml' '--enable-session' '--enable-simplexml' --with-kerberos --with-curl '--with-mysql-sock' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--with-pdo-mysql=mysqlnd' '--with-config-file-path=/usr/local/etc' --with-ldap --enable-ctype --enable-bcmath --enable-fpm --enable-zip --enable-fileinfo --enable-ftp --enable-opcache

Expected result:
----------------
The compile finishes with please run make test.

Actual result:
--------------
/usr/bin/ld: ext/ldap/.libs/ldap.o: undefined reference to symbol 'ber_scanf@@OPENLDAP_2.4_2'
/usr/bin/ld: note: 'ber_scanf@@OPENLDAP_2.4_2' is defined in DSO /usr/lib/i386-linux-gnu/liblber-2.4.so.2 so try adding it to the linker command line
/usr/lib/i386-linux-gnu/liblber-2.4.so.2: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-05-28 16:43 UTC] garrod dot alwood at gmail dot com
-Summary: LDAP compile faling +Summary: Compiling failing with LDAP flag
 [2014-05-28 16:43 UTC] garrod dot alwood at gmail dot com
Correcting the Name of the bug.
 [2014-05-29 06:48 UTC] levim@php.net
Can you try compiling with just `--disable-all --with-ldap`? It probably will still fail but it's always good to reduce it down.

The library it appears to be linking in is for a 32 bit architecture; is this a 32 bit build in general or is that a mistake?
 [2014-05-29 15:54 UTC] garrod dot alwood at gmail dot com
So it compiled just fine with the --disable --with-ldap. So now I guess I just need to find out which flag is conflicting with the --with-ldap? Also, yes this is a 32-bit machine.
 [2014-05-31 15:42 UTC] garrod dot alwood at gmail dot com
Ok, things just got weird. After I did a make clean and ran the configure and the make again it completed with the below flags. Could running a make clean have removed something that was causing problems?
 [2014-10-17 15:37 UTC] tyrael@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: tyrael
 [2014-10-17 15:37 UTC] tyrael@php.net
hi,
can you still reproduce this with the latest stable?
 [2014-12-30 10:42 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2015-05-08 15:07 UTC] alexander dot mittel at siemens dot com
same problem (openSUSE x86_64, PHP php-5.6.8),
added to Makefile to EXTRA_LIBS at the end "-llber"
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 02:01:30 2024 UTC