php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67339 HTTP v2 won't store persistent handles per process
Submitted: 2014-05-25 13:29 UTC Modified: 2014-05-26 14:49 UTC
From: pslawek83 at o2 dot pl Assigned:
Status: Not a bug Package: HTTP related
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
30 + 27 = ?
Subscribe to this entry?

 
 [2014-05-25 13:29 UTC] pslawek83 at o2 dot pl
Description:
------------
Hi Guys,

i think that's a bug, when using PHP_HTTP v2 module:

$client = new http\Client('curl', 'FH');


Persistent connection handles are stored per-process, not globally, when PHP is used as PHP-fpm fcgi. Is that supposed to work like this?

Expected result:
----------------
http\Client will pick one unused persistent connection from global, not per-process pool.

Actual result:
--------------
http\Client will pick one unused persistent connection from process local pool.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-05-25 14:10 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2014-05-25 14:10 UTC] rasmus@php.net
Persistent resources in PHP are always per-process
 [2014-05-26 14:49 UTC] mike@php.net
Rasmus is right, though, the persistent handles in pecl_http v2 are maintained by pecl/raphf and not Zend, so "always" might be a bit misleading in this case.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 09:03:37 2021 UTC