php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67337 apache_request_headers still not available
Submitted: 2014-05-24 13:53 UTC Modified: 2015-03-18 15:35 UTC
Votes:5
Avg. Score:4.6 ± 0.5
Reproduced:5 of 5 (100.0%)
Same Version:4 (80.0%)
Same OS:4 (80.0%)
From: coding at web dot de Assigned:
Status: Duplicate Package: FPM related
PHP Version: 5.4.28 OS: Debian stable latest
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: coding at web dot de
New email:
PHP Version: OS:

 

 [2014-05-24 13:53 UTC] coding at web dot de
Description:
------------
As stated earlier, apache_request_headers should be available since 5.4 in FastCGI.
http://de1.php.net/manual/en/function.apache-request-headers.php

Unfortunately, when i try to call this essential function, i get in return:

[Sat May 24 15:47:10 2014] [error] [client xxx.xxx.xxx.xxx] FastCGI: server "/var/running/php-fpm/fpm.external" stderr: PHP message: PHP Fatal error:  Call to undefined function apache_request_headers() in /var/www/arh.php on line 3

So, it would be nice to know if this is missunderstood by me, or 5.4.28 FPM/FastCGI is still not offering this function.
(and if anybody knows a workaround to this, i won't say no ;-)

Test script:
---------------
<?php

print_r(apache_request_headers());

?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-05-24 13:54 UTC] coding at web dot de
And in case if you say:
stupid debian folks missed patches, they don't have 5.4.28

root@debian ~ # php5-fpm -v
PHP 5.4.28-1~dotdeb.1 (fpm-fcgi) (built: May  7 2014 22:25:28)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
    with the ionCube PHP Loader v4.6.1, Copyright (c) 2002-2014, by ionCube Ltd.

;-)
 [2014-05-26 07:36 UTC] arjen at react dot com
Already reported at https://bugs.php.net/bug.php?id=62596

Patch available at https://github.com/php/php-src/pull/523

Now find someone who has the power to pull the change...
 [2015-03-18 15:35 UTC] kaplan@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC