php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67271 Feedback widget doesn't exist.
Submitted: 2014-05-13 21:15 UTC Modified: 2014-05-14 03:17 UTC
From: tuxedobob at comcast dot net Assigned:
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS: OS X
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tuxedobob at comcast dot net
New email:
PHP Version: OS:

 

 [2014-05-13 21:15 UTC] tuxedobob at comcast dot net
Description:
------------
The blog post for the new (awful) web layout/theme says there's a Feedback widget. There isn't.

Safari 7.0.3 on Mac OS X 10.9.2.

Expected result:
----------------
I expected a feedback widget.

Actual result:
--------------
There isn't one.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-05-13 21:18 UTC] levim@php.net
That post was for a different layout back in November. The widget has been removed.

Also, you hate the awful layout/theme but inwardly you like the 'pop' that examples and function declarations have, don't you?
 [2014-05-14 00:09 UTC] tuxedobob at comcast dot net
I don't know what you mean by "pop." Are you referring to the coloring switch where the examples have an actual white background, while the rest of the content is light gray? Because personally, I find reading dark gray (#333) on light gray (#f2f2f2) is less readable than simply #fff on #000.

Lacking a better place, I'll leave this feedback:

1. The list of functions for a class should be on the left side, not the right. The left side is where the (rest of) the navigation is, and having this one navigation element in a completely different place makes the site less usable.

2. I seem to recall the navigation tree being larger and more prominent (and therefore, easier to find and click on).

3. Overall, there just seems to be a lot of wasted whitespace (grayspace?) in the new layout. Compare http://www.php.net/manual/en/datetime.modify.php to http://web.archive.org/web/20110717093525/http://www.php.net/manual/en/datetime.modify.php. So much more information fits in the browser window with the earlier layout. The blocks of color serve to separate logical areas of the document.

I mean, don't get me wrong, the new layout is certainly "modern." It looks as though it just walked out of someone blog or WordPress site, but I don't think that's what you were going for. (Or is it?)
 [2014-05-14 03:17 UTC] sobak@php.net
-Status: Open +Status: Not a bug
 [2014-05-14 03:17 UTC] sobak@php.net
Blog post you have mentioned was related to much bigger revolution few months ago. We basically replaced our old theme existing since 90's. I'm not sure what changes you consider to be a new layout. You can always provide us some feedback via php-webmaster@lists.php.net. Just, please, make it more constructive than just word "awful".

Regards,
Maciej.
 [2014-05-14 07:41 UTC] lester at lsces dot co dot uk
Thanks for that comparison tuxedobob it shows exactly why my own situation is so badly affected by these changes. The colours are only part of the problem. I use a desktop which covers two monitors and normally have the 'help' screens on the left, so on the old setup the navigation was nicely out of the way on the left, but now it's twice as wide slap bang in the middle. Swapping screens over does not work because I just get a blank grey area instead ... even after disabling the site font for a wider profile one.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 20 18:05:43 2022 UTC