php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67194 64-bit interger
Submitted: 2014-05-03 17:25 UTC Modified: 2014-05-05 16:34 UTC
From: dan at 1ntt dot com Assigned:
Status: Not a bug Package: *Programming Data Structures
PHP Version: Irrelevant OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dan at 1ntt dot com
New email:
PHP Version: OS:

 

 [2014-05-03 17:25 UTC] dan at 1ntt dot com
Description:
------------
PHP for Windows still doesn't support 64-bit integers... I know, I know, it's been mentioned before, but we are now in 2014 (decades later) and the Windows team still haven't figured it out, time for some solid action...

Test script:
---------------
$access = 8589934592;

if( 8589934592 & access )
{
    echo "PHP Windows doesn't suck anymore!";
}
else
{
    echo "PHP Windows build is lame!";
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-05-04 08:25 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2014-05-04 08:25 UTC] rasmus@php.net
Work is underway.
 [2014-05-04 08:27 UTC] pajoye@php.net
You can test this work in progress using:

http://windows.php.net/downloads/snaps/str_size_and_int64/

or from the git branch (same name)
 [2014-05-05 16:34 UTC] dan at 1ntt dot com
This is warming news indeed!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 27 20:03:34 2021 UTC