php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67166 "make test" stalls
Submitted: 2014-05-01 11:29 UTC Modified: 2014-12-30 13:13 UTC
From: marc at phpmyadmin dot net Assigned:
Status: Closed Package: Testing related
PHP Version: 5.6.0beta2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: marc at phpmyadmin dot net
New email:
PHP Version: OS:

 

 [2014-05-01 11:29 UTC] marc at phpmyadmin dot net
Description:
------------
On a Linux x86_64 system, "make test" stalls at:
TEST 1526/11661 [Zend/tests/debug_info.phpt]

with 99% CPU.

./configure --with-apxs2=/usr/local/apache2/bin/apxs \
         --with-libdir=lib64 \
         --disable-debug \
         --enable-calendar \
         --with-gd=shared \
         --with-freetype-dir \
         --with-mysql=shared,mysqlnd \
         --with-mysqli=shared,mysqlnd \
         --with-regex=php \
         --with-png-dir=/usr/lib \
         --with-zlib=shared \
         --with-iconv=shared \
         --enable-ftp \
         --with-mcrypt=shared \
         --with-bz2=shared \
         --enable-zip \
         --with-jpeg-dir=/usr/lib \
         --enable-mbstring \
         --enable-dom \
         --enable-json \
         --with-pdo-mysql=mysqlnd \
         --with-pear \
         --enable-bcmath \
         --with-curl=shared \
         --with-ldap=shared,/usr \
         --with-gettext=shared \
         --with-snmp=shared \
         --enable-soap \
         --enable-sockets

Expected result:
----------------
"make test" completion


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-05-03 13:03 UTC] marc at phpmyadmin dot net
-PHP Version: 5.6.0beta1 +PHP Version: 5.6.0beta2
 [2014-05-03 13:03 UTC] marc at phpmyadmin dot net
Problem happens in 5.6.0-beta1 and -beta2.
 [2014-10-17 15:27 UTC] tyrael@php.net
-Status: Open +Status: Feedback
 [2014-10-17 15:27 UTC] tyrael@php.net
hi,

can you still reproduce this with the latest 5.6 stable(5.6.2 when writing this comment)?
 [2014-12-30 10:42 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2014-12-30 13:13 UTC] marc at phpmyadmin dot net
-Status: No Feedback +Status: Closed
 [2014-12-30 13:13 UTC] marc at phpmyadmin dot net
Tested with 5.6.3 and "make test" no longer stalls.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 23:01:25 2020 UTC