php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67142 Please change license (move away from PHP license)
Submitted: 2014-04-28 12:16 UTC Modified: 2014-04-28 16:00 UTC
From: math dot parent at gmail dot com Assigned:
Status: Not a bug Package: idn (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: math dot parent at gmail dot com
New email:
PHP Version: OS:

 

 [2014-04-28 12:16 UTC] math dot parent at gmail dot com
Description:
------------
Current license is "PHP". This license can't be used by anything but PHP itself.

Can you change the license to something else (Expat is a good candidate, or BSD-2-clause)?

Regards

More info:
- https://ftp-master.debian.org/REJECT-FAQ.html (#3)
- Expat: http://www.jclark.com/xml/copying.txt
- http://spdx.org/licenses/BSD-2-Clause


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-04-28 12:34 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2014-04-28 12:34 UTC] johannes@php.net
a) The PHP License can be used by "PHP software, freely available from <http://www.php.net/software/>" (clause 6), where PHP Software is not "PHP" or "the PHP Interpreter" but also PECL extensions (see Link from the clause)

b) This module is made redundant by functionality in the bundled ICU extension, as such there most likely won't be a new release.
 [2014-04-28 16:00 UTC] math dot parent at gmail dot com
Didn't knew about b).

So now, I don't care about a).

Regards
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Dec 05 15:05:52 2022 UTC