php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67137 get_meta_tags() segmentation faults
Submitted: 2014-04-27 18:35 UTC Modified: 2014-07-14 20:48 UTC
From: mesmerism at gmail dot com Assigned:
Status: Closed Package: HTTP related
PHP Version: 5.4.27 OS: Slackware 14.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mesmerism at gmail dot com
New email:
PHP Version: OS:

 

 [2014-04-27 18:35 UTC] mesmerism at gmail dot com
Description:
------------
get_meta_tags() segmentation fault since 5.4.25.  It is easily reproducible directly in interactive mode. It used to work fine somewhere before 5.4.25, but not sure which version.

It is as simple as this:

# php -a
Interactive mode enabled
<?php
$m = get_meta_tags('http://www.google.com');
?>
Segmentation fault



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-07-06 00:54 UTC] yohgaki@php.net
-Status: Open +Status: Feedback
 [2014-07-06 00:54 UTC] yohgaki@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2014-07-14 20:48 UTC] mesmerism at gmail dot com
-Status: Feedback +Status: Closed
 [2014-07-14 20:48 UTC] mesmerism at gmail dot com
5.4.30 has fixed this bug for me. Thanks
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Oct 24 09:01:23 2020 UTC