php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67107 Space in header "Accept-Encoding"
Submitted: 2014-04-22 04:30 UTC Modified: 2021-09-09 13:38 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: asainnp at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: PECL (PECL)
PHP Version: 5.5.11 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: asainnp at gmail dot com
New email:
PHP Version: OS:

 

 [2014-04-22 04:30 UTC] asainnp at gmail dot com
Description:
------------
I had 3 various installations with (debian, ubuntu and slackware) and versions of php >=5.4, one is 5.5.9 ...pecl version on is: 1.9.4
and all of them reported ERROR on command: 
$ pecl install oci8
no releases available for package "pecl.php.net/oci8"
...
after searching for reason i found solution:
adding space to empty "Accept-Encoding:" request header inside file ~/PEAR/REST.php, solved the problem on all 3 systems that i have...
install, download, remote-info... all works now (and before - not)
...
i am hoping that this bug was not already known...
...
it is related to all functionalities of pear/pecl, not just oci8 package.
...
maybe it is http server fault and not a bug (header can be empty) but it is better to prevent failures with this space added.

Test script:
---------------
when someone has this problem (and surely lot of people must reach it),
this bash script will solve it:

#!/bin/bash
target=`pecl config-get php_dir`/PEAR/REST.php
        [ -f "$target" ] || { echo file $target not found; exit; }
sed -i 's/Accept-Encoding:\\r\\n/AcceptEncoding: \\r\\n/g' $target




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-04-22 04:35 UTC] asainnp at gmail dot com
-Summary: Space in header "Accept-Decoding" +Summary: Space in header "Accept-Encoding"
 [2014-04-22 04:35 UTC] asainnp at gmail dot com
correction:

sed -i 's/Accept-Encoding:\\r\\n/Accept-Encoding: \\r\\n/g' $target
 [2021-09-09 13:38 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-09-09 13:38 UTC] cmb@php.net
If this is still an issue for you, please report that in the
proper bug tracker[1], or even better yet, submit a pull
request[2].

[1] <https://pear.php.net/bugs/>
[2] <https://github.com/pear/pear-core/pulls>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 14:03:37 2021 UTC