php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6710 Could not execute mail delivery program
Submitted: 2000-09-13 06:09 UTC Modified: 2000-10-30 19:49 UTC
From: cnewbill at onewest dot net Assigned:
Status: Closed Package: *Mail Related
PHP Version: 4.0.1pl2 OS: Redhat 6.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: cnewbill at onewest dot net
New email:
PHP Version: OS:

 

 [2000-09-13 06:09 UTC] cnewbill at onewest dot net
I have a script that queries an ODBC source and sends an email to the addresses it pulls out.

I for the life of me cannot figure out what is causing this error "Could not execute mail delivery program".  I am using the mail() function.  The only pattern I can see is it happens in large chunks with gaps of successful ones.  Any ideas on where to look?

Sending email to (19561) Lynn Chadwick...
ERROR: Could not execute mail delivery program.
Sending email to (19569) Derril Sparks...
ERROR: Could not execute mail delivery program.
Sending email to (19578) JaNell Ure...
ERROR: Could not execute mail delivery program.
Sending email to (19591) Edward Zaladonis...
OK
Sending email to (19595) Eric Bennion...
OK

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-29 00:26 UTC] sniper@php.net
Check your php.ini file for sendmail_path. And try also
running sendmail in the command line..

--Jani
 [2000-10-30 10:16 UTC] cnewbill at onewest dot net
Nope that would have been too easy.

I have been swamped lately so I have not updated this ticket, I apologize.

The problem is the server was running out of file descriptors.  The previous fd created by sendmail does not seem to close right away and since this program was moving at a brisk pace all the fds got used.
 [2000-10-30 19:49 UTC] sniper@php.net
Please use sleep() between mail()'s. 

--Jani
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 23:01:32 2024 UTC