php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67075 Pecl couln't extract mongo package
Submitted: 2014-04-15 00:35 UTC Modified: 2014-12-27 21:32 UTC
Votes:22
Avg. Score:4.9 ± 0.3
Reproduced:21 of 21 (100.0%)
Same Version:17 (81.0%)
Same OS:20 (95.2%)
From: lovetostrikep at gmail dot com Assigned: derick (profile)
Status: Closed Package: mongo (PECL)
PHP Version: Irrelevant OS: Ubuntu 14.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lovetostrikep at gmail dot com
New email:
PHP Version: OS:

 

 [2014-04-15 00:35 UTC] lovetostrikep at gmail dot com
Description:
------------
Installing mongo through pecl doesn't work for Ubuntu 14.04(PHP 5.5.9). I can confirm it works on 13.10(PHP 5.5.3). For 14.04, I just downloaded the package and phpized successfully. What happened was that the command put 'package.xml' outside the extracted folder. I can simply move it inside the mongo folder and phpize it, but I think this should be fixed. I'm not sure if this is Ubuntu or PHP problem but since it uses Pecl, I would report it here.

Test script:
---------------
pecl install mongo

Expected result:
----------------
Extract and install mongo extension for PHP.

Actual result:
--------------
could not extract the package.xml file from "/build/buildd/php5-5.5.9+dfsg/pear-build-download/mongo-1.5.1.tgz"
Download of "pecl/mongo" succeeded, but it is not a valid package archive
Error: cannot download "pecl/mongo"
Download failed
install failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-04-15 22:32 UTC] burkal975 at gmail dot com
I am having the exact same problem.
pecl install ANYTHING
Does not work with the error message given by the OP.
Something is going wrong during the extraction process.

There was a known bug with php 5.5 & Archive_Tar library, which was fixed in it's latest version. So, I checked and made sure I have the latest Archive_Tar and yes I have the latest Archive_Tar and yes the problem is still there. Unless it is a very new bug, it is not Archive_Tar.

I really wanna dig deeper and troubleshoot&debug the problem but I dont know how to. I even couldn't manage to isolate the problem so I can say it is a PHP problem or Ubuntu 14.04 problem.

I installed debian testing which comes with php 5.5.11 and the problem is not there.
 [2014-04-25 13:17 UTC] kusakyky at gmail dot com
I have the same proble.
I can`t install any package from pecl.

version info:
-------------
$ pear info archive_tar|head -n1
ABOUT PEAR.PHP.NET/ARCHIVE_TAR-1.3.11

$ php -v
PHP 5.5.9-1ubuntu4 (cli) (built: Apr  9 2014 17:08:27)

$ uname -a
Linux user 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:08:14 UTC 2014 i686 i686 i686 GNU/Linux

$ lsb_release -d
Description:    Ubuntu 14.04 LTS

-----------

But, in another pc, where installed ubuntu 14.04 x64, all works well.
 [2014-04-25 21:31 UTC] burkal975 at gmail dot com
I just noticed that as well. I guess the problem is only occurs on 32bit installations and things seems to work normal on 64bit Ubuntu 14.04
 [2014-05-08 19:25 UTC] jaaa at pobox dot sk
I have the same problem, 32bit Kubuntu 14.04, PHP 5.5.9, Archive_Tar 1.3.11, PEAR 1.9.4.
 [2014-05-09 11:49 UTC] jaaa at pobox dot sk
So this is the problem (at least in my case):
https://bugs.launchpad.net/ubuntu/+source/php5/+bug/1315888
https://bugs.php.net/bug.php?id=53829

No solution yet.
 [2014-06-17 16:17 UTC] dave at davidhbrown dot us
tldr: it's probably not a Ubuntu 14.04 x32-only problem because my production server is running 14.04 x64 and is getting the same failure with imagick.

-------------------------------- 

I wonder if this is something to the side of both PHP and Ubuntu. I'm trying to install imagick and getting the same error on my production server (hosted with linode) but not on my test server (VirtualBox in Windows host). I try hard to keep them as much the same as possible, installing security updates every couple of days. 

Except for the host names, they report identical versions for all of the following: php, gzip (gunzip), tar, perl (pecl), lsb_release, and uname

However, the production server is using a newer Linux kernel:

(fails to install imagick:)
# uname -a
Linux www.******.*** 3.14.4-x86_64-linode40 #1 SMP Tue May 13 12:25:05 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux

(installs fine:)
# uname -a
Linux ******* 3.13.0-29-generic #53-Ubuntu SMP Wed Jun 4 21:00:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

So, I took a snapshot of that virtual machine so I can try updating the kernel to see if that has anything to do with anything...

# uname -a
Linux ******* 3.14.4-031404-generic #201405130853 SMP Tue May 13 12:54:33 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Well, good I guess that this still installs. It would be a little disconcerting to think that a kernel version could make this blow up.

However, I do think that it's not a Ubuntu 14.04 x32 problem because my production server is running x64.
 [2014-06-17 18:19 UTC] dave at davidhbrown dot us
What do you think the chances are this could be related to the problems with some PHP versions being compiled for large file support and so having a gzopen64 function instead of the regular gzopen?

My production server (which cannot install from PECL) has gzopen64 while my test server (can install) has gzopen.

I noticed this when trying to add a plug-in to Piwigo which hits the following:
    if (!function_exists('gzopen'))
    {
      die('Abort '.basename(__FILE__).' : Missing zlib extensions');
    }

Then I tried:

pecl install --nocompress imagick

...and got further than before. I don't have some of its dependencies right yet, but I was able to get pear working on it.

(Note to whomever: changing the name of a function without mapping the old name is a really annoying thing.)
 [2014-06-17 18:25 UTC] dave at davidhbrown dot us
Okay, 

pecl install --nocompress imagick

definitely worked for me once I had the libraries reinstalled (too many config changes fighting this today!) If any of you can verify it works for mongo, too, that would be great.
 [2014-06-22 14:53 UTC] yuvilio at yahoo dot com
I compiled 5.5.13 on Ubuntu 14.04 x64 and got those pecl errors.  When I tried 5.5.11 instead, pecl worked without a hitch (installed imagick, xdebug, uploadprogress).
 [2014-06-22 14:58 UTC] yuvilio at yahoo dot com
Installing mongo with pecl on 5.5.11 worked as well for my on Ubuntu 14.04 x64.
 [2014-07-02 20:15 UTC] cheempz at yahoo dot com
I second comment "[2014-06-17 18:19 UTC] dave at davidhbrown dot us" that it may be due to large file support.  Tested on Ubuntu Trusty with 5.5.9+dfsg-1ubuntu4.2 package installed:

---- 64 bit ----
PHP from the the php5 package is not compiled with lfs

# php-config --phpapi
20121212

pecl install mongo works

---- 32 bit ----
PHP from the php5 package is compiled with lfs

# php-config --phpapi
20121212+lfs

pecl install mongo gets "could not extract the package.xml file" error

pecl install --nocompress mongo works
 [2014-09-17 17:14 UTC] rimtzg at gmail dot com
"pecl install --nocompress mongo" works fine
 [2014-12-27 21:32 UTC] derick@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: derick
 [2014-12-27 21:32 UTC] derick@php.net
This should be fixed in all the latest packages.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Apr 10 21:01:26 2021 UTC