php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #66974 Multi Core Capability
Submitted: 2014-03-28 17:27 UTC Modified: 2014-03-28 18:13 UTC
From: jfha73 at gmail dot com Assigned:
Status: Not a bug Package: Performance problem
PHP Version: master-Git-2014-03-28 (Git) OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
40 - 33 = ?
Subscribe to this entry?

 
 [2014-03-28 17:27 UTC] jfha73 at gmail dot com
Description:
------------
Hey guys,

Now a days CPUs are coming with more and more cores, it would be nice if PHP could handle multiple cores instead of multiple threads so it can get better performance.

Thanks,


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-03-28 18:13 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2014-03-28 18:13 UTC] johannes@php.net
I don't understand what "multiple cores instead of multiple threads" means,anyways: PHP's purpose is to handle web requests in a shared nothing architecture. By that architecture it can be easily be scaled linearly vertically (over multiple machines) as well as horizontally (bigger machines= easily and thus use all available CPU power.

Threading inside individual scripts in this context brings more complications and less benefit. PHP offers asynchronous operations and we will increase that, where it makes sense. To provide a good user experience the suggested approach is to offload CPU-intensive tasks to background workers using gearman or rabbitmq or such.

For experimental use of threads from within a script one can look into http://pecl.php.net/pthreads The core distribution doesn't provide this on purpose.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Mar 28 19:01:27 2020 UTC